Posted 4/25/2018

On May 1, 2018, AgBanking Online (ABOL) will be upgraded and require all web browsers to meet the security standard TLS 1.0 or higher. Customers trying to log into ABOL with an outdated browser will receive the message, "Stronger Security Required", and be required to update their browser before accessing ABOL. Below are the browser versions that support TLS 1.1 and higher:

Internet Explorer - version 11 or higher
Microsoft Edge - all versions
Google Chrome - version 38 or higher
Mozilla Firefox - version 27 or higher
Safari (Desktop) - versions 7 and higher for OS X 10.9 (Mavericks) and higher (7)
Safari (Mobile) - versions 5 and higher for iOS 5 and higher

Protecting your data is critical and TLS 1.1 and above provide significantly higher security controls.

 

Comments